http 0 Error on local server for web demo

+1 vote

I have an http 0 error on the web demo when I have the rcp host as 127.0.0.1 and also have the correct rcp port. Any ideas on how to fix this? This only occurs after I choose a node.

 

On the first webpage I also get Notice: Undefined index: in C:\xampp\htdocs\multichain-web-demo-master\index.php on line 13 which is set_multichain_chain($config[$chain]);

 

 

 

asked Jun 18 by anonymous

1 Answer

0 votes
It sounds like you may have your Web Demo config file set up incorrectly, or it's not readable by the web server. Have you checked the general server error logs for more information?
answered Jun 19 by MultiChain
default.name=TutChain               # name to display in the web interface
default.rpchost=127.0.0.1          # IP address of MultiChain node
default.rpcport=6468           # usually default-rpc-port from params.dat
default.rpcuser=multichainrpc       # username for RPC from multichain.conf
default.rpcpassword=**  # password for RPC from multichain.conf

My config file is like this so im not sure what could be an error there? Also the error logs basically tell me the same thing

[Wed Jun 19 09:45:46.731660 2019] [ssl:warn] [pid 13160:tid 680] AH01909: www.example.com:443:0 server certificate does NOT include an ID which matches the server name
[Wed Jun 19 09:45:46.794662 2019] [mpm_winnt:notice] [pid 13160:tid 680] AH00354: Child: Starting 150 worker threads.
[Wed Jun 19 09:48:41.023605 2019] [php7:notice] [pid 13160:tid 1976] [client ::1:55687] PHP Notice:  Undefined index:  in C:\\xampp\\htdocs\\multichain-web-demo-master\\index.php on line 13, referer: http://localhost:8080/multichain-web-demo-master/?chain=default

the config array looks like
Array ([default] => Array([name] => ETFChain[rpchost] => 45.34.47.239[rpcport] => 6468[rpcuser] => multichainrpc[rpcpassword] => 28VzcXDQeCGSUBptaqPztSR8ua5GnbjzdGihDGpF3mFL) )

and print($chain) prints nothing
Not sure if configuration is wrong
...