error: hexdump is required for tests

+1 vote

I'm on Ubuntu 16.04 (Docker image), with the following Dockerfile:

---------------------------------------------------------------

FROM ubuntu:16.04

WORKDIR /

ADD . /multichain

RUN apt-get update \
   && apt-get install -y software-properties-common \
    && apt-get install -y build-essential libtool autotools-dev automake pkg-config libssl-dev git python python-pip \
    && add-apt-repository ppa:bitcoin/bitcoin \
    && apt-get update \
    && apt-get install -y libdb4.8-dev libdb4.8++-dev \
    && pip install pathlib2 \
   && apt-get -y install nano \
   && apt-get -y install curl \
   && apt-get -y install wget

WORKDIR /multichain

RUN export MULTICHAIN_HOME=$(pwd) \
    && mkdir v8build \
    && cd v8build \
    && wget https://github.com/MultiChain/multichain-binaries/raw/master/linux-v8.tar.gz \
    && tar -xvzf linux-v8.tar.gz \
    && cd $MULTICHAIN_HOME \
    && ./autogen.sh \
   && ./configure \
   && make \
   && cp src/multichain-util /usr/local/bin/ \
   && cp src/multichaind /usr/local/bin/ \
   && cp src/multichain-cli /usr/local/bin/

---------------------------------------------------------------

But I get the error "hexdump is required for tests". It happens when running the ./configure.sh script

asked Apr 4 by milkncookiez

1 Answer

+1 vote
 
Best answer

There's a Linux tool called hexdump that it sounds like you need to install before compiling MultiChain.

answered Apr 4 by MultiChain
selected Apr 6 by milkncookiez
...