Published to stream on first server but value of stream item's confirmation remained 0 and no blocktime

+1 vote
Hi,

I have two servers connected to one chain. I published an item to a stream on first server but the confirmation's value of the stream item remained 0 and no blocktime was shown until I stopped and reconnected the second server to the chain.

Is it something wrong with the parameters of my chain?

Thank you.

 

chain: getblockchainparams
{"method":"getblockchainparams","params":[],"id":1,"chain_name":"chain"}

{
    "chain-protocol" : "multichain",
    "chain-description" : "MultiChain chain",
    "root-stream-name" : "root",
    "root-stream-open" : true,
    "chain-is-testnet" : false,
    "target-block-time" : 15,
    "maximum-block-size" : 8388608,
    "default-network-port" : 2781,
    "default-rpc-port" : 2780,
    "anyone-can-connect" : false,
    "anyone-can-send" : false,
    "anyone-can-receive" : false,
    "anyone-can-receive-empty" : true,
    "anyone-can-create" : false,
    "anyone-can-issue" : false,
    "anyone-can-mine" : false,
    "anyone-can-activate" : false,
    "anyone-can-admin" : false,
    "support-miner-precheck" : true,
    "allow-arbitrary-outputs" : false,
    "allow-p2sh-outputs" : true,
    "allow-multisig-outputs" : true,
    "setup-first-blocks" : 60,
    "mining-diversity" : 0.75000000,
    "admin-consensus-upgrade" : 0.75000000,
    "admin-consensus-admin" : 0.75000000,
    "admin-consensus-activate" : 0.75000000,
    "admin-consensus-mine" : 0.75000000,
    "admin-consensus-create" : 0.00000000,
    "admin-consensus-issue" : 0.00000000,
    "lock-admin-mine-rounds" : 10,
    "mining-requires-peers" : true,
    "mine-empty-rounds" : 10.00000000,
    "mining-turnover" : 0.50000000,
    "first-block-reward" : -1,
    "initial-block-reward" : 0,
    "reward-halving-interval" : 52560000,
    "reward-spendable-delay" : 1,
    "minimum-per-output" : 0,
    "maximum-per-output" : 100000000000000,
    "minimum-relay-fee" : 0,
    "native-currency-multiple" : 100000000,
    "skip-pow-check" : false,
    "pow-minimum-bits" : 8,
    "target-adjust-freq" : -1,
    "allow-min-difficulty-blocks" : false,
    "only-accept-std-txs" : true,
    "max-std-tx-size" : 4194304,
    "max-std-op-returns-count" : 10,
    "max-std-op-return-size" : 2097152,
    "max-std-op-drops-count" : 5,
    "max-std-element-size" : 8192,
    "chain-name" : "OpenTradeBlockchain",
    "protocol-version" : 10010,
    "network-message-start" : "f8d8c3e2",
    "address-pubkeyhash-version" : "00a0c44d",
    "address-scripthash-version" : "055e8131",
    "private-key-version" : "80df6a91",
    "address-checksum-value" : "92040998",
    "genesis-pubkey" : "037930c82dac510b53f086ee76f676f52b16731e479522304b2d4e2e586f427870",
    "genesis-version" : 1,
    "genesis-timestamp" : 1525321581,
    "genesis-nbits" : 536936447,
    "genesis-nonce" : 347,
    "genesis-pubkey-hash" : "8cfdf2888eb8849da232ce4d856380b2a5b61bef",
    "genesis-hash" : "0032bc3cb028c848aa23a7ba9aa14ce48a94b3ec70071bda549f1eab4c31458e",
    "chain-params-hash" : "9c2b7cf8f257aea0f0308251034d8e22a0d0ee2f305657b5e545dda93ea7a659"
}
asked May 28 by Jeremiah

1 Answer

+1 vote
It looks like the mining was stopped because of mining-diversity constraint. Your setting is 0.75. This mean: if you have 2 nodes having address with mining permission, both of them should be up to allow mining in round-robin fashion.

I suppose before you restarted the second server, they were not connected to each other for some reason. You can use getpeerinfo to make sure nodes are connected.
answered May 29 by Michael
...