OS information and apt upgrade command..

+1 vote

Execute the following command while compiling normally.

 

$openssl version

OpenSSL 1.0.2g  1 Mar 2016

$ uname -a
Linux lee-VirtualBox 4.10.0-35-generic #39~16.04.1-Ubuntu SMP Wed Sep 13 09:02:42 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

$ sudo apt update

...

$ sudo apt upgrade (After running this command, build will not work normally.)

...

$ make clean

...

$ openssl version

OpenSSL 1.1.0f  25 May 2017

...

$ make

...
Making all in src
make[1]: Entering directory '/home/lee/src/hdac-0.15/src'
  CXX      multichain/hdacd-multichaind.o
In file included from /usr/include/openssl/bio.h:20:0,
                 from /usr/include/openssl/conf.h:13,
                 from /usr/include/boost/asio/ssl/detail/openssl_types.hpp:19,
                 from /usr/include/boost/asio/ssl/context_base.hpp:19,
                 from /usr/include/boost/asio/ssl/context.hpp:27,
                 from /usr/include/boost/asio/ssl.hpp:19,
                 from ./rpc/rpcprotocol.h:17,
                 from ./rpc/rpcserver.h:11,
                 from multichain/multichaind.cpp:9:
/usr/include/boost/asio/ssl/detail/impl/openssl_init.ipp: In constructor 'boost::asio::ssl::detail::openssl_init_base::do_init::do_init()':
/usr/include/boost/asio/ssl/detail/impl/openssl_init.ipp:43:23: error: expected id-expression before '(' token
     mutexes_.resize(::CRYPTO_num_locks());
                       ^
In file included from /usr/include/boost/asio/ssl/detail/openssl_init.hpp:100:0,
                 from /usr/include/boost/asio/ssl/context.hpp:29,
                 from /usr/include/boost/asio/ssl.hpp:19,
                 from ./rpc/rpcprotocol.h:17,
                 from ./rpc/rpcserver.h:11,
                 from multichain/multichaind.cpp:9:
/usr/include/boost/asio/ssl/detail/impl/openssl_init.ipp:46:66: error: expected id-expression before ';' token
     ::CRYPTO_set_locking_callback(&do_init::openssl_locking_func);
                                                                 ^

... 

related to an answer for: compile error with OpenSSL 1.1.0f
asked Sep 20, 2017 by Jae Min Lee

1 Answer

+1 vote
OK - thanks for the details. It's an incompatibility between the Boost library used by MultiChain and that version of OpenSSL. We will look into it in due course.
answered Sep 21, 2017 by MultiChain
...