Compiling MultiChain on Mac OS X Mojave

+1 vote
Greetings,

I'm trying to compile the Multichain code on Mojave

Xcode 11

I've tried many Boost versions 1.57 / 1.59 / 1.60

but encounter many warnings and errors ex :

Would you please help me find the correct libraries versions, please ?

 

/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:43:23: error:
      expected unqualified-id
    mutexes_.resize(::CRYPTO_num_locks());

/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:46:66: error:
      expected unqualified-id
    ::CRYPTO_set_locking_callback(&do_init::openssl_locking_func);

 

-------------------------

With boost 1.57 the error are :

/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:46:66: error:
      expected unqualified-id
    ::CRYPTO_set_locking_callback(&do_init::openssl_locking_func);
                                                                 ^
/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:47:56: error:
      expected unqualified-id
    ::CRYPTO_set_id_callback(&do_init::openssl_id_func);
                                                       ^
/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:64:32: error:
      expected unqualified-id
    ::CRYPTO_set_id_callback(0);
                               ^
/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:65:37: error:
      expected unqualified-id
    ::CRYPTO_set_locking_callback(0);
                                    ^
/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:66:7: error:
      expected unqualified-id
    ::ERR_free_strings();
      ^
/usr/local/Cellar/openssl@1.1/1.1.1d/include/openssl/err.h:257:29: note:
      expanded from macro 'ERR_free_strings'
# define ERR_free_strings() while(0) continue
                            ^
In file included from rpc/rpcserver.cpp:8:
In file included from ./rpc/rpcasio.h:17:
In file included from /usr/local/include/boost/asio/ssl.hpp:19:
In file included from /usr/local/include/boost/asio/ssl/context.hpp:29:
In file included from /usr/local/include/boost/asio/ssl/detail/openssl_init.hpp:100:
/usr/local/include/boost/asio/ssl/detail/impl/openssl_init.ipp:68:7: error:
      expected unqualified-id
    ::EVP_cleanup();
      ^
/usr/local/Cellar/openssl@1.1/1.1.1d/include/openssl/evp.h:962:25: note:
      expanded from macro 'EVP_cleanup'
#  define EVP_cleanup() while(0) continue
asked Nov 26 by anonymous
edited Nov 27

1 Answer

0 votes
MultiChain for OS X requires Boost version 1.57. Could you please try compiling it with that, and then post any *errors* you see (don't worry about warnings).
answered Nov 27 by MultiChain
Thank you. I've started with 1.57 (as mentioned in the Mac.md file)
I've inserted the first couple of errors at the end of the question.
Thank you
Thanks for your reply. So it looks like something broke in the build process on this newer version of Mac OS X. We will look into this when we can – in the meantime perhaps you can find a Mac running an older version?
...